Web-Mobile System Requirements

For the best Voxy experience, we recommend that you keep your systems updated with the latest versions of the supported browsers and operating systems. We may support other browsers and operating systems, but we do not test on them.

For the Web application, Voxy supports:

  • Latest version of Chrome
  • Internet Explorer 11* and higher on Windows 7 and higher

For the mobile application, Voxy supports:

  • Android 6.0.1 and higher
  • iOS 10.3.3 and higher.

Additionally, always make sure that your Voxy mobile app is the latest version available in the Play Store (for Android users) and the App Store (for iOS users).

*Pronunciation Practice and Command Center are not supported on Internet Explorer.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.